Query Parameters

I am having an issue with MySQL Query Parameters.
My second parameter, as shown in the image, has the company name, which is often separated by commas. Because of this, the Query Parameters interprets it as a parameter separation. In the case I showed, the first part of the string ends up as $2 and pushes the second part to $3. Is it possible to fix this?

Information on your n8n setup

  • n8n version: 1.26.0
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: W10

hello @miguelraatz

you need to validate the input before sending it to the SQL node. Like this: {{ $json["row"]["1"].replaceAll(",", "_") }} or {{ $json["row"]["1"].replaceAll(",", ".") }}


and the workflow

1 Like

Perfect, that’s exactly it. Thank you very much for the response.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.