RabbitMQ Credentials throw error: “Frame size exceeds frame max”

Describe the problem/error/question

I cannot connect RabbitMQ account located in the Amazon (Amazon MQ) due to the “Frame size exceeds frame max” error.

I’ve found in the Internet, that it could be due to the protocol mismatch (Amazon uses amqps instead of amqp) but I do not see how to change it in the settings.

Information on your n8n setup

  • n8n version: 1.4.0

Hi @barn4k, is there a chance you haven’t enabled the SSL option in the RabbitMQ credentials? This option seems to have fixed the problem for @Gowthaman_Prabhu over here when using AWS MQ:

1 Like

hi @MutedJam
i saw that option but I can’t figure out what it wants from me (the docs won’t help a lot in that case)

So what is CA certificate? CA for the RabbitMQ server or client (n8n)?
and client certificate for what client? n8n? and why it is needed…
I thought that the communication with the server within SSL would have only server-side encryption and I do not need to point any certificates there…

And I didn’t found any SSL related settings on the AWS side, so I don’t know where to take the requesting info from. Plus what is the input format for that fields? Should I specify the path to the certificates or the certificate itself in the PEM format?

Hi @barn4k, you should be able to disable the “Passwordless” option if you don’t need to provide your own client certificate.

I tried reproducing this first hand, but it seems AWS has other plans for me at the moment :frowning:

Other hosted services also using SSL/TLS are however working fine with this setting, for example cloudamqp. The CA Certificates field can stay empty here:

Sending a message works as expected as well:

So perhaps you want to try simply leaving the CA Certificates field empty?

1 Like

oh, jeez, that was totally unexpected for me.
Disabling Passwordless button fixed the issue


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.