Raspberry Pi 4 - Orange Pi Zero error in "refresh" auth of google sheets

Describe the issue/error/question

I got little automation reading (or writing in other workflow) some basic data form google sheets.
Primarily i got them going on raspberry pi 4 - everything works great. I got rotation of 7 days with prepared credentials of trusted up. But it worked.
Tried on RP 3A - got some speed issues/hangouts.
After purchasing Orange Pi Zero i’ve installed it from docker image from arm64 image shared on docker hub.
It succeed and I’ve imported my workflows but they seem to work in this manner:
test run always ok
making them active and triggering after several minutes renders 401 error in authorization almost instantly - when i got back to templates and trying to trigger sheets node it comes with this error also. When i clicke “refresh them” - this pencil icon it looks ok. i can login with already used ones. After that i can run node in workflow view. After run in executions situation becomes same. I got 401 error.
I can do it again and again.
I cannot understand what is going on. I’ve tried at first creating NEW Oauth but it was ending same way. Finally i got that i can do login in google to have this info that i have already given permissions but it helps me to make one or two runs. After several minutes everything is 401.

Please help

What is the error message (if any)?

ERROR: Authorization failed - please check your credentials

Request failed with status code 401

Information on your n8n setup

  • **n8n version: latest
  • **Database you’re using (default: SQLite): default
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: docker

Hey @fishaa,

Welcome to the community :tada:

Can you confirm which version of n8n you are running? There was an issue in the release tagged with latest so we pulled it but if you are on that release you will have an issue.

The quick option would be to install 0.221.2 or 0.220.1 which will fix the issue assuming you are on 0.222.0

Thanks a lot for great tool!
I am on 0.222.0 OMG


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.