Read Binary File error when execute the entire workflow

Describe the issue/error/question

Build a workflow to trigger when a new XML file is dropped into a folder. >> extract xml to json >> then get the value of the keys I needed to post to another app.

What is the error message (if any)?

Cannot read properties of null (reading ‘$error’)

Please share the workflow

Share the output returned by the last node

When i manually execute the read binary file node XML content will be extracted on a data key. But if i execute the entire workflow to drop the file to trigger… it will return the above error. Apparently execute the entire workflow read binary file node fails to extract the XML and return a empty data key.

Making good progress after many tries on getting many other nodes to work. Including the local trigger file node. But this is tripping me up.

Updating my own question:

When I turn the workflow active, the execution went through correctly. Not sure why when I trigger manually the entire workflow, it will fail to read binary file? Comtemplating to delete my question but I thought it might be better leaving it here to help someone else if they encounter the same error.

Hello leonard,
I just gave it a shot and wasn’t able te reproduce your problem, all worked fine for me.

  • Are you using n8n desktop, docker or npm?
  • What version on n8n are using?
  • What OS are you using?

Hi Marcus,

Thanks for responding to my question.

The error still there but it is not affecting me as I can manually trigger all the nodes to cycle through.
Once the workflow go active, it is working ok.

Anyway here are the specifications the n8n instance is on:

Verison 0.195.4
Mac accessing the n8n instance

Spoke too soon. Tested the active workflow. Some xml file read successfully… Some dont’. Read binary file node return a file with no content… which will throw an error at XML node

When i check the execution list, I found a bunch of errors.

Anyone with advise?

Let me retract this post. The active workflow works well. I was on a bad network when dropping the file into the watched folder. Not sure why it causes an error on some of the files.

However the execute workflow button (non active workflow) still throws an error when i drop the file into the folder.

Wait I am wrong again. The execute workflow button does work. Strange but my bad for spamming here.

1 Like