[Read Binary file node] Strange behaviour when reading a certain spreadsheets

Hello again,

I am having a problem with reading excel sheets, I usually get sent excel files from a supplier with product data, yesterday the excel sheet could not read. When I run the workflow the read spreadsheet node returns empty data, and when I click download file it shows a blank doc

Describe the issue/error/question

When I run the workflow the read spreadsheet node returns empty data, and when I click download file it shows a blank document.

I will upload the files up the file called “this works” is an example of a spreadsheet that can be read. the other files are the same file that is unreadable but in different formats ie; CSV, XLSX, XLS.

Ive tried several formats but something about the data because it also has an external SQL connection and causing it not to read as expected.

all of the files are in here FUCKED – Google Drive

I would really be appreciative if someone could go to the trouble of running these files to try and reproduce my error. I would really like to know why this is happening to me.

What is the error message (if any)?

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • Latest version running on a docker container

Hi @Josh-Ghazi, I tried reading the x.xls file, but this seems to work fine for me:

Can you confirm if this problem only occurs when using the Read Binary File node or also when reading your file through other nodes (I downloaded this file directly from Google Sheets when testing)?

it runs through local file trigger to a folder on the server VM (ubuntu) which is shared on the network and is also synchronized with the NAS as well. they all should not work apart from the THIS WORKS file.

The strangest thing happens, I tried to read them off the google sheets node and low and behold it works normally. Then today i tried the reload the spreadsheet normally through the local file trigger and it also works fine??

I believe it might be as you said, something to do with the filesystem perhaps the file is being read before it is totally written onto the HDD? I was working remotely yesterday with a mobile hotspot connection connecting through an old firewall vpn so it could be likely that its trying to read a file that was not completely written? I know that the first few nodes of my workflow are almost instant.

Also the THIS WORKS file only contains a single row of data which in theory would be written to file faster than a 30+ row sheet. so it makes sense that it works because it is writing to the hard drive quicker than the other sheet.

I will add a wait node at the file trigger and see if this problem persists, I will probably have to change the name of this thread to Local file trigger or Read binary file node, because it seems that the spreadsheet node is not responsible for this issue

1 Like

Hm, that’s an interesting observation indeed. Perhaps @kik00 has an idea what might be happening in the scenario you have described? I remember he was working on binary data handling a while back, so I reckon he’d be the best person to clarify. I’d thought each node was self-contained (meaning the next node only starts running once the previous one finishes), but perhaps it doesn’t work like that for all filesystems.

1 Like

Well if it helps I’m running the server on Ubuntu Desktop 22.04 and I have N8N running as a docker container, It can see the files because I have mounted the local directory as a volume in the docker container, this is shared across the network with SMB and lastly the directory is filesynced using QNAPs QSYNC onto the NAS.

So there is several points of weakness in this setup

1 Like