Read Binary Files

Describe the problem/error/question

I am trying to read Binary files from my disk. But no matter what types of files I try to read, the node gives no output. Can Anyone help me please?

What is the error message (if any)?

No error is being showed. Just no data is read even though the path im providing is correct.

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • **n8n version:1.0.1
  • **Database (default: SQLite):default
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):own
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):npm
  • **Operating system:Windows

Hi @Nazih_Saba :wave: Welcome to the community, and I’m sorry you’re running into this!

Since you’re running n8n via npm, can you take a peek at this post from my teammate? It might have the solution for you:

I am running n8n locally, And im trying to avoid running n8n with docker for the mean time just so I can run commands from my local disk

Hi @Nazih_Saba , as mentioned in the post I linked, are you sure you’re running the npm process as Administrator? That might fix this up :+1:

Yes I tried running n8n as an administrator, it gave me the same output :frowning:

Hmmm, could you try to change the path from C:\Users\96181\Downloads\new_audio2.mp3
to C:/Users/96181/Downloads/new_audio2.mp3 and see if that works?


It worked!!! Thank you so much for your time and help!!! :blush: :blush: :blush: :blush:


Glad I could help you get this sorted :smiley:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.