Regex E-mail validation not working when worfklow run with schedule trigger

Hi there!

I am integrating 2 systems together but one of the systems (Salesforce) is forcing me to validate e-mails when creating or updating an account.

Here is the check:

The “If email is correct or empty” check if the following regex matches with the e-mail field: ^(((?:[^<>()\.,;:\s@“]+(.[^<>()\.,;:\s@”]+)*)|(“.+”))@(([[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}])|(([a-zA-Z-0-9]+.)+[a-zA-Z]{2,})))?$

The regex accepts empty fields as it is not mandatory to mention an e-mail.

When I run the workflow manually, not e-mail is being sent. However, when it runs using the schedule trigger, I recieve 3 e-mails mentionning that there are errors in an e-mail while the e-mail field is empty …

Any guess?

BTW: here is the workflow setup but I can’t find the latest executions, it this normal? Thanks

I use N8N cloud, 1.14.2.
Please DM for more account related information, thanks

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

here is the regex correctly formatted ^(((?:[^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,})))?$

Well, it is related to another workflow, my bad, solved it!

2 Likes

This topic was automatically closed 7 hours after the last reply. New replies are no longer allowed.