Regex match doesn't work 1.25

Describe the problem/error/question

After the recent update 1.25, I began to redo my workflow replacing old nodes with new ones. Faced with the problem that the switch node v.3 doesn’t work with regular expressions. example: incoming data “#invoce” switch node => string => matches regex => /#([Ii]nvoi[c])/g
I don’t get data at the output
(old one node v2 working with those data correctly)

What is the error message (if any)?

Please share your workflow

Share the output returned by the last node

[
  {
    "update_id": 861039796,
    "message": {
      "message_id": 2387,
      "from": {
        "id": 246905212,
        "is_bot": false,
        "first_name": "Aleksandr",
        "last_name": "U",
        "username": "snyaify",
        "language_code": "ru",
        "is_premium": true
      },
      "chat": {
        "id": -1001623232130,
        "title": "snyaify-test",
        "is_forum": true,
        "type": "supergroup"
      },
      "date": 1706004243,
      "message_thread_id": 219,
      "reply_to_message": {
        "message_id": 219,
        "from": {
          "id": 246905212,
          "is_bot": false,
          "first_name": "Aleksandr",
          "last_name": "U",
          "username": "snyaify",
          "language_code": "ru",
          "is_premium": true
        },
        "chat": {
          "id": -1001623232130,
          "title": "snyaify-test",
          "is_forum": true,
          "type": "supergroup"
        },
        "date": 1697204307,
        "message_thread_id": 219,
        "forum_topic_created": {
          "name": "Важное",
          "icon_color": 16766590,
          "icon_custom_emoji_id": "5312241539987020022"
        },
        "is_topic_message": true
      },
      "text": "#invoices",
      "entities": [
        {
          "offset": 0,
          "length": 9,
          "type": "hashtag"
        }
      ],
      "is_topic_message": true
    }
  }
]

Information on your n8n setup

  • n8n version: 1.25 (next)
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker compose
  • Operating system: ubuntu 22.04

Hey @Snyaify1,

Thanks for reporting this one, I have popped in a PR which can be found below to fix this one. For now another workaround would be to just use #([Ii]nvoi[c]) for your matching pattern which should work.

1 Like

New version [email protected] got released which includes the GitHub PR 8422.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.