Regex match not working

Describe the problem/error/question

I have an if block with a regex match that is looking for numbers. I want to see if a field has a time in there and not empty or text. I’ve added the pictures with the true and false output. If there are numbers in the field “Aanwezig” It should be routed to true as many items do but one makes it through to false.

What is the error message (if any)?

I don’t get any error messages my item just get’s routed the wrong way. I don’t have any problems with other items just one item currently that has the time of 8:45. Items that have another time like 9:30, 9:00 14:00 work fine.

Please share your workflow

“meta”: {
“instanceId”: “366f4a9fc10563b263fb89d6b646c70de14b644609bbf261438f456074f9ccf0”
“nodes”: [
“parameters”: {
“conditions”: {
“string”: [
“value1”: “={{ $json[‘Aanwezig’] }}”,
“operation”: “regex”,
“value2”: “[0 - 9]”
“id”: “55f5b4bd-c0cf-47e9-9b54-b06b003301a3”,
“name”: “IF6”,
“type”: “n8n-nodes-base.if”,
“typeVersion”: 1,
“position”: [
“connections”: {}

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

## Share the output returned by the last node
<!-- If you need help with data transformations, please also share your expected output. -->

## Information on your n8n setup
- **n8n version:**
- **Database (default: SQLite):**
- **n8n EXECUTIONS_PROCESS setting (default: own, main):**
- **Running n8n via (Docker, npm, n8n cloud, desktop app):**
- **Operating system:**

you have decimal points in the numbers.


This was sort of my solution. I changed it to just \d to check if there were any numbers as this one doesn’t fully work.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.