Release 0.218.0 throws error while trying to build a custom image

We are selfhosting n8n. And we started migrating from v212 to 218.0. I deleted the node modules directory and ran pnpm install followed by pnpm build. But it fails throwing the below error that is related to typescript version 4.9.4. All our codebase uses 4.9.5

Note : It builds correctly until v0.217.2

What is the error message (if any)?

## Information on your n8n setup
- **n8n version:** 0.218.0
- **Database you're using (default: SQLite):** postgres
- **Running n8n with the execution process [own(default), main]:** 
- **Running n8n via [Docker, npm,, desktop app]:** Docker Compose

Hey @Mahesh_Thiru,

I have built 3 custom images this week on 0.218.0 can you share the command you are running and what the changes are for your custom image?

1 Like


I created a branch that tracks our n8n master branch (git checkout --track -b <br_name> origin/master). Then pulled the code from it. Now at the root directory, I ran

rm -rf node_modules
pnpm install
pnpm build

Note : I may do some silly error here. But it worked fine until 217.2. And once I upgrade to 218 or pulled the current master it fails.

Is there anything different about your branch? Like why are you building a custom image?

As a test can you do a clean checkout of our master branch in a new folder and try to build the custom image for that and see what happens?

1 Like

@Jon ,

Since we render n8n in a iframe, except for some styling changes in ui, all other code are same. Hence we build a custom image . I will try the approach suggested by you and will provide an update soon.

Thank you again.

1 Like

Building the code in different folder resolved the issue. I dont know why it thrown an error. But Now its resolved. Thank you.

1 Like

Hey @Mahesh_Thiru,

That is good to hear, I suspect something odd was cached and it just needs clearing.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.