RSS Feed Trigger not executing

Describe the problem/error/question

RSS Feed Trigger Not Executing regularly. If I restart the container it executes everything it missed.

What is the error message (if any)?

No Errors, it just fails to execute on a regular basis

Please share your workflow

Information on your n8n setup

  • n8n version: 1.20.0
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): Default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu 22.04

Hey @netris,

Sorry for the delay this wasn’t showing up as unread for me, Are you using the community node or the node that we include for this it looks like the community node but it is worth checking? I have been doing some testing recently with the node and feeds that have been reported to not work, I am just going to set up a test with https://feeds.feedburner.com/TheHackersNews to see what happens.

Hi @Jon
I was using the community node you created and previously suggested. After a recent update which included it natively, I tried switching over to the included one, and still have the same issues.

Hey @netris,

That is worrying as I am not able to reproduce it, It could be related to an issue fixed in 1.24.1 though. I still have the rss feed going and it looks like it is posting.

Do you see any errors or anything in the n8n logs?


It’s configured to run every hour when I re set it up with the built in RSS Feed Trigger but as you can see, it’s very sporradic, then it didn’t run since the 9th. Yesterday was update night, so that would be why it tried to trigger again, then after logging in tonight I had it test execute, and it worked (And subsequently spammed by slack channel with all the backlogged articles.)

I’m now up to version 1.22.4, I’ll try updating shortly (If your Docker build process has been fixed and “latest” is actually the latest now.

Hey @netris,

I have just checked this morning and it looks like the node has missed a couple of posts, I will do some digging and see what I can find

hello, I’m just testing n8n, freshly installed, and I’m having exactly the same problem. I have several RSS feeds and none of them seem to work. However, when I run the test manually, it sends me something.

Hey @Floflobel,

Welcome to the community :cake:

I have a test running right now for this so I can try and work out what is going on. Part of the problem is a test feed I have been using works as expected everytime.

Can you share some of the feeds you are using?

Everything seems to work fine when I click on “Test workflow”, it’s only the trigger that doesn’t work.

That is, every time there’s new content it doesn’t see it and therefore doesn’t launch my workflow.

For my part, I retrieve RSS feeds from the “FreshRSS” tool. What I can try to do for you is to create an RSS feed that constantly displays new content (every 2 minutes), for example, and send it to you.

Hey @Floflobel,

Yeah sure that could work, I have worked out part of what is going on and I have a possible solution that I need to test but when running every minute we check the feed for anything published in the last minute, Some feeds like hackernews refresh hourly so this means if something was published 5 minutes ago and you run every minute the time now - 1 minute won’t match the published time of the article and that is causing the problems.

I am looking at changing this so rather than checking since the last run we check since the last published date which I think will solve most problems.

This is honestly what needs to happen. My previous setup when I used Huginn (and even the ghetto one I had before this plugin was Available) kept a record of the last rss record it knew about and then next run it looked for any records between that one and now. That’s the most correct way to handle checking for RSS updates.

I will also say that this plugin seems to work flawlessly part of the time and then just not work at all part of the time. So I don’t think the feeds are the issue. I experience this with my hacker news feed, xkcd feed and a couple others.

Hey @netris,

The issue itself is down to how I checked for new articles, What I didn’t realise at the time was some feeds don’t instantly update and will instread release a batch at once so some checks would be missed. I should have this fixed before next weeks release.

Hey @jon is this something that it’s already released? I found RSS Feed Trigger to malfunction more than usual on v1.29.1 (feeds not coming in, or a ton of old feeds bring posted at once).

Also I’m facing issues to activate workflows with RSS Feed Trigger in this version:>

There was a problem activating the workflow: “Cannot read properties of undefined (reading ‘isoDate’)”

:person_shrugging: not sure where that isoDate is coming from

Hey @nukeador,

Oddly enough it should be a lot better now, We now store the last date of a feeds item on the run and use that on the next run to see if anything is newer rather than using the runtime of the workflow. This does mean that we expect the feeds to be correctly setting the timezone as well as if they don’t follow the standard correctly and do this there will be other issues.