Running n8n in Replit

Describe the problem/error/question

I’m trying to get n8n to run on Replit

What is the error message (if any)?

When hooking up to the Postgres DB in Replit, I get error saying that I need SSL connection to DB

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:
  • n8n version: 1.21.1
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Replit

Hey @Derek_Cheung,

Welcome to the community :tada:

We don’t officially Replit but luckily it looks like the error you are getting is something that can be fixed by setting some env options.

For Postgres we have a few SSL/TLS options you can set depending on your Postgres configuration which I have listed below for you, You can find the full list and descriptions here: Environment variables reference | n8n Docs

DB_POSTGRESDB_SSL_CA
DB_POSTGRESDB_SSL_CERT
DB_POSTGRESDB_SSL_KEY
DB_POSTGRESDB_SSL_REJECT_UNAUTHORIZED

1 Like