Schedule Trigger error - wrong frequency

Schedule Triggers with wrong frequency

I set Schedule Trigger with trigger interval = DAY, days between triggers = 1. instead of triggering once today at set time, it triggered every minute!
Here’s trigger rules:

And here’s trigger frequency:

What might be the problem here and how can I fix it?

Information on your n8n setup

n8n Version 1.8.2 Community Edition

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

in my experience restarting the docker container fixed weird trigger behaviour.(like multiple executions)

Hey @A_App,

I have not been able to reproduce this, Was the schedule ever set to 1 minute maybe for testing?

Good to know
Thanks!

No, settings were as shown on screenshot

I fixed it by adding exact minute at which it should be triggered. Now it triggers precisely at specified time.

1 Like

I missed that trigger at minute was empty, We should set that as a required field or default it to 0 if empty.