Schedule trigger not executed with cron expression

I have a problem with the schedule trigger node.
When I set to be executed from a cron expression the flow doesn’t run.
Instead if I use some standard values like day execution or something else it work.
Can somebody help me?
Thanks advance.

“meta”: {
“instanceId”: “b756f6391c293aaca2eef1e2dc5a98e610cfcb965eac32582eb154099e835920”
“nodes”: [
“parameters”: {
“rule”: {
“interval”: [
“field”: “cronExpression”,
“expression”: “43 10 5 5 *”
“id”: “b70aec3a-46ed-4c26-a7f7-a2c732b8e5b6”,
“name”: “Schedule Trigger”,
“type”: “n8n-nodes-base.scheduleTrigger”,
“typeVersion”: 1,
“position”: [
“connections”: {}

## Information on your n8n setup
- **n8n version:** 0.218.0
- **Database (default: SQLite):**
- **n8n EXECUTIONS_PROCESS setting (default: own, main):**
- **Running n8n via (Docker, npm, n8n cloud, desktop app):** Docker, installed on our server
- **Operating system:** Rocky linux 8

Hi @dawesf - can you clarify exactly what you’re trying to do with your Cron expression? Are you trying to run it specifically on all days in May at 10.43 for example? Otherwise the next time that expression would run is 2023-05-05 10:43:00, which hasn’t happened yet - which is why the flow isn’t running :sweat_smile:

Hi Emarald,

I initially tried with a more structured expression, namely, At 10:00 on every day-of-month from 1 through 5 in May. 0 10 1-5 5 *.
When I noticed that the flow wasn’t running, I changed when it should run.
I can assure you that I’ve been trying to get this to work for 2 days and every time the flow doesn’t run I change the hour and minutes to see what happens.
I also checked the stream and server timezone and they are aligned.

Hi @dawesf - I tried just there with a pretty specific execution criteria: 30 10 * 1-5 0-6 and it worked as expected:

One quick question - do you have the workflow set to save all executions? While in the workflow, you can click the three dotted menu in the top right, then settings, and then do something like this:

I noticed you’re on quite an older version of n8n - there might have been updates to how the schedule trigger works in more recent versions. Can you try to update n8n and see if this fixes this up for you?

HI @EmeraldHerald,

i tried with your expression and works.
But if i try for example with:
30 10 * 5 0-6
30 10 1-5 5 *
(I adjusted the hours and minutes based on when I ran the tests.)

nothing happening.

Yes i have set to save all executions how you can see in the screen.

Which is the last stable version to upgrade to?
Thanks advance.

Hi @EmeraldHerald,

i found the issue.
The problem was for the month.
I used the number of the month, and nothing happened, but when i have tried with the name(may), the flow works.
Here is the final expression that i used.
43 13 1-5 may *

The final test will be tomorrow, because how you can see, i need that the flow to be executed in a certain interval of days.
I’ll update the post tomorrow.
Thank you for now and i wish that issue may be helpful for others members of the community.

1 Like

Hi @EmeraldHerald,

today the Schedule trigger runs again, so I can confirm that the solution that I posted yesterday, using month name instead month number is working properly.
Thanks for your support.

1 Like

No problem @dawesf - really glad to hear we got this sorted for you! Thanks as well for posting your solution for others in the community to find :muscle:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.