Scheduler triggers failing to activate "invalid timezone" after copying data to new server

:wave: I have run n8n in Docker for a little while now and want to move which server was running my instance. In an attempt to preserve my data I copied the .n8n folder across to the new server. Everything seems to be working fine, except scheduler triggers- existing ones and new ones fail to activate, saying There was a problem activating the workflow: “Invalid timezone.”

This seems to be happening consistently with all scheduler nodes. I’ve tried setting the environment variable GENERIC_TIMEZONE to America/New_York, but otherwise I’m at a loss. Any ideas?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

The original instance was on version 1.0.5 (and unable to update for unrelated reasons) and the new one is 1.17.1. But with how I would update- just recreating the container with the new version and leaving the volume alone- this shouldn’t matter too much? Maybe?

Hey @mrhappyma,

Welcome to the community :cake:

If you just copy the data it can get tricky but I would still expect it to work, The generic timezone though only sets the default so you may need to check the timezone for each workflow to see what they are using under the settings.

Oh! I hadn’t seen the workflow settings. Thanks :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.