Seatable trigger: oldest item instead of newest (manual execution)

Describe the issue/error/question

When manually executing a workflow with the Seatable Trigger node, I get back one item, but it’s the oldest one. That’s rather unhelpful for testing, cause I want to add an entry, then manually test that entry instead of an old one. Anything I’m missing here? Maybe the manual execution just sorts the _ctime in reverse order? In production mode it works, when I add a row that new row triggers the workflow correctly.

Information on your n8n setup

  • n8n version: 0.164.1
  • Database you’re using (default: SQLite): PostgreSQL
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker, with expanded Dockerfile

Here is a solution: Create a column in Seatable, call it Created and use Created Time as type.

Then add these following two nodes:

Copy paste this in n8n


Connect the start node to the first.
Connect the second to where the Seatable trigger goes as well.

That way you can test by getting all elements, sorted by creation time, keep last one (disable workflow and deactivate trigger or it will trigger from there instead of the start node).

And when it’s all good, just disable these three nodes and only the trigger will start the workflow (workflow needs to be active then of course!).

1 Like