Send attachment in smtp email

Hello

i have a docker n8n i am testing to send a spread sheet as attachment but when i receive the email the attachment is a file without extension.

the file is originally comes from sql query

how can i fix that?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

I am not 100% sure but you can attach the ending either manually or from the fileExtension field. For the attachement field (i am not sure about this, i am very new to n8n) you might have to put the actuall data of the binary. As it looks now you are attaching the file information instead of the file. Happened to me before :slight_smile:

Here is how i set the file name of an mp3. Its not the same but related…
image

Thanks for your replay , but it didn’t seem to work in my case using data

also using binary it gives error

NodeApiError: options.attachments.split is not a function
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/EmailSend/v2/send.operation.js:289:19)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/EmailSend/v2/EmailSendV2.node.js:87:22)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:672:19)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:652:53

i have fixed it by adding the file extension to the file name in the spreadsheet node.

but i think my main issue before is how to make the spreadsheet output as data and not [object object]