Service Unavailable Error

Hi I facing this error when trying to take my workflow live - any idea what I can do ?

It sounds like the server can not be reached

If you use a regular WooCommerce node and set it up to return all orders and you just execute that single node (which is not connected to anything else) does that work?

hi @jan i tried executing that single node and it gave the same error

Hello @Saandhy_Ganeriwala1,

Do you mind share workflow JSON? (select nodes in n8n and copy and paste between these chars ``)

@Saandhy_Ganeriwala1 sounds then like the WooCommerce credentials are wrong or not set up correctly (most likely the “WooCommerce URL”).

Best to check again the documentation. They should roughly look like this:

Thanks @jan ill have a look and get back

Hi @jan
Ill give some more details. We are facing 2 kinds of problems:

error:

Woocommerce credentials popup:

json of workflow: Workflow 1 - Google Docs

(My gut feel is that it is happening because the Woocommerce Store URL doesnt have the domain ‘.com’)

error: Woocommerce Trigger node is not detecting orders (even though they are being created on Woocommerce)

Woocommerce credentials popup:

json of workflow: Workflow 2 - Google Docs

(here also, the woocommerce store URL has a ‘.in’ and not a ‘.com’ domain - is that the reason for the issue?)

Hi @jan @Shirobachi @harshil1712
Can anyone pls help in the above?

  1. The problem is for sure not the domain (.in). It looks like it is simply not set to the correct value. The API of a shop can be accessed via /wp-json/wc/v3 which would be in your case https://bakezbydaizy.in/shop-2/wp-json/wc/v3. If you test it, you will see that it does not exist. If you use only https://bakezbydaizy.in/ it resolves at least correctly. No idea how the whole multishop thing works however in WooCommerce. But if you set it to the above value you should probably be able to get it working and you will then see how it behaves with multiple shops.

  2. Sadly no idea why it is not triggering. Do the webhooks get registered correctly for sure? (you can check that in the UI, here an article I found: Using Webhooks - WooCommerce). So does it exist, is the URL correct, is it active, does it have the correct topic, …?

1 Like

Thanks @jan

  1. this problem got solved using https://bakezbydaizy.in/
  2. still checking. will update :slight_smile:

Good to hear! Good luck!