Set Node returning a lot of item when I Only want one

Hey I am getting a lot of item in return from set node but I only want one pls tell me how can I make it one

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

the set node, like almost all other nodes will return an item per input item.
If you want to reduce it, set it to run only once in the node settings (cog icon)
Or add a limit node after or before the set to limit it to one item.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.