"Set sender email" gone in Gmail node after update


I noticed that the “Set sender email” in Gmail node is gone after the update.
Any plans on bringing it back?

There is “Override” setting in the pre-update Gmail nodes, but I can’t find it in the post-update ones.
Any plans on getting rid of that as well?

Information on my n8n setup:

  • n8n version: 0.195.5
  • Database you’re using: SQLite
  • Running n8n via Docker

Hey @Rafix,

There is a Sender Name option under Options, Is that what you are looking for?


Hey @Jon

Not really.
From what I gather it is now limited to specifying Sender Name and has been stripped of the option to insert Sender emai with <> brackets as it was before the update.
So now all emails come from the main email and not from the aliases.

Hey @Rafix,

You are right, Looking at the code for the node we only set the name now as the email needs to be the same one that authenticates in the API so could lead to errors. We now automatically get the users email from the profile.

Were you previously using a different email address from the authenticated user? As a workaround if you take one of your old nodes from a previous workflow you can copy / paste it into a new workflow and you will be able to use the previous version.

I have added this to our internal feature request tracker so that we can evaluate adding it back in.

Thanks @Jon for your quick reply.
That is probably why my email often ended up in spam.

Thanks for looking into it and helping me out.
Best regards,