Setting all workflows to active not working

Describe the problem/error/question

The docs say that I can do n8n update:workflow --all --active=true,

However the code seems only to be able to set individuals workflows activate by id.

Running the suggested command actually deactivates all workflows: n8n/packages/cli/src/commands/update/workflow.ts at f2939568cf399e67214e89bc7f859323aaeda8dd · n8n-io/n8n · GitHub

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.21.1
  • Database (default: SQLite): postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system:

Hey @Neil_Buckley,

Welcome to the community :cake:

Good spot, This is something we are aware of and are tracking it as PAY-1206 internally. I have added this thread to the ticket so you can be notified once this has been resolved.

1 Like

Thanks a mill!

1 Like

This should be fixed in the next release :blush:

1 Like

Thank you!!

New version [email protected] got released which includes the GitHub PR 8412.