Setting up Docker

Attempting to install n8n in docker but this issue has stopped my attempts the documentation was very lacking in information regarding this

At line:2 char:7
+     --name = n8n \
+       ~
Missing expression after unary operator '--'.
At line:2 char:7
+     --name = n8n \
+       ~~~~
Unexpected token 'name' in expression or statement.
    + CategoryInfo          : ParserError: (:) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : MissingExpressionAfterOperator

Any help or direction towards a solution would be appreciated

Hey @BramKn,

Are you using compose or just the standard docker run command?

Are you also able to share the full command or file you are running with anything important replaced with mock values.

It looks like it is just a docker syntax error at the moment.

Hi @Jon ,
You miss me?

Think you meant to tag @BraveHeroo :slight_smile:

1 Like

Hey @BramKn,

I did :smiley:, That will teach me to answer on my phone without double checking what I am sending.

1 Like

For the first question i tried it with the standard run command

For your second question i ran the command given by the documentation

docker run -it --rm \
	--name n8n \
	-p 5678:5678 \
	-v ~/.n8n:/home/node/.n8n \

ill try using compose

Are you by any chance using PowerShell on Windows @BraveHeroo? It might not like the line breaks or the Unix path, so maybe try formatting the command like this instead (replace C:\Users\BraveHeroo\.n8n with any other path you want to store n8n data in):

docker run -it --rm --name n8n -p 5678:5678 -v C:\Users\BraveHeroo\.n8n:/home/node/.n8n n8nio/n8n
1 Like

This solved my problem instantly please add it to the documentation to help other people as well it is extremely lacking in cases like these