Shopify Integration Get All Orders

Describe the problem/error/question

I’m new to n8n, I trying to automate some workflows for Shopify and Google Sheets, I’m in trial period.
First automation is about to get all orders from Shopify and update to Google Sheets.
Everything works fine if you don’t set any filter when connect to Shopify (Option section is not defined).
The problem is when I try to get all orders specified by status=any and the Created at Min =‘01/01/24’
I got an error: run out of memory.
Looks like the problem is when I tried to get orders with status “closed” it takes too long, more than 10 minutes and even I can’t stopped it, however if I filter by status to “open”, then return some values.
If I can’t get all orders at least I would like to get all orders from current year.
Total orders in shopify are 14k and from this year are 712, looks n8n can’t process these 712 records.
I read other topics in the forum but it’s not clear the right approach to achieve this automation.
I know I could use httpRequest nodes but it seems too much complex.
Is there any solution with shopify built-in integrations?

What is the error message (if any)?

run out of memory

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

## Share the output returned by the last node
<!-- If you need help with data transformations, please also share your expected output. -->

## Information on your n8n setup
- **n8n version:**
- **Database (default: SQLite):**
- **n8n EXECUTIONS_PROCESS setting (default: own, main):**
- **Running n8n via (Docker, npm, n8n cloud, desktop app):**
- **Operating system:**

version = [email protected]
Running via cloud (web browser)
OS: Windows 11 Pro

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Byteshell_Soluciones :wave: Welcome to the community :cake:

Unfortunately it sounds like you’re processing too much data at once - you could instead try to limit the number of items you receive from Shopify, splitting this in batches of 50-100. You could even do this in a separate sub-workflow to try to ensure less memory is used - would that be something you could do? :slight_smile:

I didn’t know about subflows.
I’ll try to see if does work.