Shopify triggers invalid request

I tried to use shopify triggers and work follow the example in doc, but it’s fail even I just created a shopify trigger node.

After I created the node and click execute, it show error " Your request is invalid or could not be processed by the service"

how can I fix it? I already approve all the right in my shopify account of the API

Welcome to the community @Fong_Tom

Ok, just tested it and it’s working fine for me. Can you share your workflow?

I also tested. Works also totally fine for me.

When I tried to break it by using wrong credentials, subdomain or did other stuff wrong I always got totally different error messages. The only way I was able to get the error message you wrote about, is if I use localhost instead of a proper domain. So I assume that you either run n8n locally without a tunnel or you have your server not configured correctly.

Yup, I found that will be the address is invalid in Shopify issue.
I tried to setup local server, it won’t show the error again, however after I click execute node, it will infinite waiting the Webhook-call.

Does it mean I need to really have a domain in DS for external route? Or can I just use my ip address for redirect?

That sounds correct. It is supposed to wait. As soon as you start the workflow manually, it will wait till it receives a call from Shopify. So you would start the workflow and then do the action you are listening for (like for example update an order). n8n will then receive the call and displays you the data it did receive.

If you run it locally for testing it is enough to use the tunnel as written in my previous post. If you run it in production on a proper webserver, you would need an own subdomain. Theoretically would also be an IP enough. That would however cause problems with most third party trigger nodes (probably also Shopify) as they do not allow to register webhooks on IPs. They only allow a proper domain and most time does it also have to run via https.