Slack error missing name

Hi n8n !! :wave:

I am using the 0.162.0 version and I am having an issue with the Slack node. I have a workflow creating a Slack channel for each new client and since Slack has pretty restrictive caracters (no space, period and upper case caracters, it returns the invalid_name_specials errors otherwise) I want to be able to standardize every name that comes in. I use the java functions to replace the caracters :

but when executing Slack returns the error missing required field: name

Any tip for me ? :pray:

Thanks !

How many items do you send into the node? Is it possible that the expression does not resolve for all of them?

only one if i’m understanding correctly :

{
“nodes”: [
{
“parameters”: {},
“name”: “Start”,
“type”: “n8n-nodes-base.start”,
“typeVersion”: 1,
“position”: [
240,
300
]
},
{
“parameters”: {
“authentication”: “oAuth2”,
“resource”: “channel”,
“channelId”: “test a name”,
“additionalFields”: {}
},
“name”: “Slack”,
“type”: “n8n-nodes-base.slack”,
“typeVersion”: 1,
“position”: [
680,
300
],
“credentials”: {
“slackOAuth2Api”: {
“id”: “5”,
“name”: “vincent.carignan”
}
}
},
{
“parameters”: {
“values”: {
“number”: [],
“string”: [
{
“name”: “name”,
“value”: “test A name”
}
]
},
“options”: {}
},
“name”: “Set”,
“type”: “n8n-nodes-base.set”,
“typeVersion”: 1,
“position”: [
460,
300
]
}
],
“connections”: {
“Start”: {
“main”: [
[
{
“node”: “Set”,
“type”: “main”,
“index”: 0
}
]
]
},
“Set”: {
“main”: [
[
{
“node”: “Slack”,
“type”: “main”,
“index”: 0
}
]
]
}
}
}

I simplified the workflow so I can post it here