Slack node credential stopped working in new n8n cloud version?

Describe the problem/error/question

I created a Slack credential via Slack API, tested it, it works :

In my workflow in the Slack node, it cannot load the list of channels:

It says “Please check your credential”

It was working correctly in a previous version of n8n cloud, with the same credential.

Am I missing something ?

Thanks in advance

Information on your n8n setup

  • n8n version: n8n.cloud 1.6.1
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud

Hey @raphaelh,

Are you using a bot or user token? It could be that you have not added the scopes to your Slack app so that would be the first thing I would check. You could also try clicking on the 3 dots next to Fixed above the channel box and select refresh to see if that shows anything.

1 Like

hey @Jon

Thanks for your quick reply

I’m using a bot

On https://api.slack.com/apps/xxx I have the following :

and
image

In OAuth & Permissions I have :
image

I tried “Reinstall to Workspace” but didn’t fix the problem:
image

I tried “Refresh List” but didn’t fix the problem either:

Hey @raphaelh,

The bot would need access to channels:read if you want it to read a list of channels, You may also need other scopes to be set depending on what you are doing.

hey @Jon

I added the channels:read scope :

Reinstalled to the workspace

Deleted and recreated the Slack node, and still have the same problem

Can I get some logs on n8n side on what’s going on under the hood?

What I don’t understand is that the old Slack node is working with the same credential:

If I select “By name” it works :
image

The problem seems to be with “From list”. Do you know which permission is needed for “From list”?

Hey @raphaelh,

Looking at the Slack api docs the from list option needs the channels:read scope, the api call we make is this: conversations.list method | Slack it could be that you need one of the others listed as well.

For those having the same problem, I had to add groups:read scope in addition to channels:read :

It’s for private channels

thanks @Jon for your help

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.