Slow UI in big scenarios

Hello!

I have some big scenarios. After updating to Version 1.14.2, these scenarios began to slow down significantly. Sometimes I have to wait several minutes to change the text inside a node.

Is there any limit on the number of nodes in one scenario?

Disabling extensions does not change the situation.

Before the update, working with the same scripts was much faster.
Can you advise me something to solve this problem?

  • n8n version: 1.14.2
  • Running n8n via: npm
1 Like

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi Pilar, could you share which version you were upgrading from, plus the other missing info mentioned above?

Unfortunately, I don’t know which version was the previous one.
We have updated again to Version 1.18.2.
The problem of slow user interface is still relevant.

Hey,
I am facing the same issues.
Probably this is because of the new switch as I only have a slow interface when I have at least one switch node in the workflow.

And the new dynamic switch node was introduced only a few versions back. Maybe 1.14…

Cheers.

1 Like

Thank you, we have a lot of switch nodes.

We’ll look into this, but in the mean time one solution could be to replace the switch node with several filter nodes (one on each branch), which is logically the same thing:

1 Like

New version [email protected] got released which includes the GitHub PR 8022.