SMTP configuration with Docker installation


Can any help me here, with how we can use configure the SMTP setting for Office 365? As I tried to do the configuration for the new installation but it gives an error

here is a problem with your SMTP setup! 140641509833088:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:…/deps/openssl/openssl/ssl/record/ssl3_record.c:331:


I have checked here all kinds of possible blogs and support writeups but have not been able to find the solution.

Hi @patelbhavin

Welcome to the community!

For microsoft it is using port 587 (out of the top of my head) with TLS correct?
In n8n you need to disable SSL for this to work.

1 Like

Hi @patelbhavin, in addition to what @BramKn said you might want to consider using the purpose-built Outlook node instead of the SMTP one as Microsoft is getting rid of many other authentication methods: Deprecation of Basic authentication in Exchange Online | Microsoft Docs (SMTP might still be available, but only if actively used).

This node would use a REST API and authenticates via OAuth2 which should cause less trouble after the initial set up.

1 Like

Thanks for reply…

Hi @MutedJam… Thanks for the reply… so This Outlook node will work for user creation also … as when ever I tried to create a member it gives me the error.

If any more configuration required for Outlook node then please let me know

Ah sorry, for some reason I thought this was abound sending emails as part of the workflow rather than as part of the user management functionality. The latter would indeed require an SMPT setup. As suggested by @BramKn I’d first disable the SSL option (through the N8N_SMTP_SSL=false environment variable) from looking at the error.

1 Like

Disabel SSL means? … can you please help me to understand this in some more elaborated manner as i am using reverse proxy for nignx… forwarding to localhost:5678

Hello @BramKn and @MutedJam ,

Thanks a lot, my friends… Now its working and I am able to send registration mails


Awesome, glad to hear :raised_hands:

Thanks for confirming!