SMTP credentials bug?

Hi,

I’ve tried to add a SMTP credential but for some reason it ends up changing the password to seomthing completely different?

I change the password, click save, save the workflow and refresh the page. Then it goes back to this value…

I’ve also tried updating the version so I’m curently running the latest one. (Didn’t work last version either).

Mail command failed: 550 5.7.1 [M12] User [[email protected]] not authorized to send on behalf of (242a5f61-d54b-11ee-8f27-b520e3c7e1da)

Information on your n8n setup

  • n8n version:: 1.27.2
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Operating system: I don’t know

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

That’s fine that it changes password for some string. That’s because it encrypts the password internally. Just enter the password in that field and hit Save. You won’t be able to retrieve the value.

Thank you for your respone @barn4k !

I see, so the change has nothing to do with the error code I’m getting and not being able to send emails?

Yes. The error says you cannot access the mailbox or shared account due to the lack of permissions. It’s not the same as Authentication error (401 Error)