Some execution shows as running in Executions tab

I have a workflow that takes less than 1 second. But sometimes when I go to the execution tab, I see that some are still running for more than minutes!
This mostly happens when a false condition occurs in the if node and I don’t have any commands after that, because I expect the workflow to end. I even thought maybe the problem was with the IF node, so I added a “no operation” node, but it didn’t make a difference.

Information on your n8n setup

  • n8n version: 1.3.1
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker):

Hi @alisen, welcome to the community!

I am very sorry you’re having trouble. Purely based on your description I suspect your executions might be stuck on a node which is attempting an HTTP request, but is not receiving an answer from the server it’s talking to. Most n8n nodes have very long timeout settings (the default being 300 seconds), so it will take a while before such an error is shown.

Can you confirm if the execution from your screenshot (started 15:07:51) is still running for you?

I had stopped that specific execution manually, but the executions even later than that time are still running (as shown in pictures).

for example, look at task 14:23:09 which was running for about 3 hours, when I stopped the execution, the last operated node was the IF node, where the False condition occurred.

the last running node of all of my running executions are the If or Switch nodes (not http nodes), which There are situations that I don’t want to define the next step because I expect that nothing will happen and the executaion will be completed, but it’s not.

also, I should again mention that in most of the cases, everything is ok, but in some random cases, the execution keeps running.

Now that looks odd indeed. Are there any errors in your server logs?

Here is my server log:

I’m not a technical man, so I don’t know is every thing okay or not :frowning:

I also changed the final node with the Set node, but no different. still having running executions. It looks like it’s a problem with large requests per second!

Hi again @MutedJam , can you help me with that issue? :frowning:

Hi @alisen, most of the errors you have shared are coming from the database and wouldn’t be related into the running executions.

What’s interesting are the Only running or waiting executions can be stopped and 62524 is currently canceled lines though. These suggest the execution have actually finished when you tried accessing them. Do these IDs (61532, 62452, 62524) belong to the executions that keep showing up as “running” for you and did these log lines appear when you tried accessing your executions?

n8n shows the IDs in a separate column of the global execution list:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.