Spotify connect button does nothing (self-hosted)

Describe the issue/error/question

When trying to add a spotify credential nothing happens in firefox. I’m not even redirected to the login page.

  • I’ve setup my spotify correctly; it works in the windows app
  • There is error message or anything else in the web app
  • No error in firefox developper console
  • No error in the docker container log
  • Everything works in brave browser

Please share the workflow

I’m trying to use the “add spotify liked song to monthly playlist” template. But the problem s in the credential page; not the workflow directly

Information on your n8n setup

  • n8n version:: latest (docker compose)
  • Database you’re using (default: SQLite): Mysql
  • Running n8n with the execution process [own(default), main]: No idea; probably default
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker compose

My compose service:

n8n:
    image: n8nio/n8n
    restart: unless-stopped
    container_name: n8n
    hostname: n8n
    networks:
      - web
    depends_on:
      - traefik
    environment:
      - PUID=${PUID}
      - PGID=${PGID}
      - TZ=${TIMEZONE}
      - DB_TYPE=mysqldb
      - DB_MYSQLDB_DATABASE=n8n
      - DB_MYSQLDB_HOST=mariadb
      - DB_MYSQLDB_PORT=3306
      - DB_MYSQLDB_USER=n8n
      - DB_MYSQLDB_PASSWORD=${N8N_MYSQL_PASSWD}
      - N8N_HOST=n8n.${PUBLIC_DNS}
      - N8N_PORT=5678
      - N8N_PROTOCOL=https
      - NODE_ENV=production
      - WEBHOOK_URL=https://n8n.${PUBLIC_DNS}/
      - GENERIC_TIMEZONE=${TIMEZONE}
    ports:
      - "5678:5678"
    volumes:
      - "${CONF_FOLDER}/n8n:/home/node/.n8n"
    labels:
      - "traefik.enable=true" 
      - "traefik.http.routers.n8n.entrypoints=http"
      - "traefik.http.routers.n8n.middlewares=n8n-https-redirect"
      - "traefik.http.routers.n8n.rule=Host(`n8n.${PUBLIC_DNS}`)"
      - "traefik.http.routers.n8n-secure.tls=true"
      - "traefik.http.routers.n8n-secure.service=n8n"
      - "traefik.http.routers.n8n-secure.entrypoints=https"
      - "traefik.http.routers.n8n-secure.tls.certResolver=resolver"
      - "traefik.http.routers.n8n-secure.rule=Host(`n8n.${PUBLIC_DNS}`)"
      - "traefik.http.services.n8n.loadbalancer.server.port=5678"
      - "traefik.http.middlewares.n8n-https-redirect.redirectscheme.scheme=https"
      - "traefik.docker.network=web"

Hey @valentin_bancarel,

Welcome to the community :fire:

Can you confirm the version? Latest should be 193.5 but we do updates fairly often so it is worth putting the full version.

It is very odd that it works in Brave and not Firefox but it would suggest maybe a browser setting or plugin. Do you have any extensions installed that might prevent pop ups or block things?

Thanks !

Ok, I feel dumb now; I disabled my ad block and others yesterday but I missed the most obvious clue:
image

As excepted it works perfectly once I allow popups.

Sorry for taking your time with such a silly stuff :smiley: And thank you very much for the good work, I love it <3

1 Like

Hey @valentin_bancarel,

No worries it happens :slightly_smiling_face: