Spreadsheet file doesn't take all my datas

Hello,

In my workflow, I want to put datas in an XLSX file using the Spreadsheet file node, but it returns me just the first item of my list.

Would you have an idea of the problem ?

Thanks,
Ben

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @BenJ,

Can you share the workflow? I have done a quick test and it looks like it should be working as expected so it is possible that the data you are using needs to be tweaked a bit. Below is the workflow I used to test can you run the same workflow and let me know what that does for you?

Hi @Jon,

Indeed it’s good, I’ve made many workflows with this node in the past.
I tried to delete the current node I had and create a new one and it worked, I don’t really understand why actually.

Thank you !

1 Like