SQL Agent in Chat Step

Describe the problem/error/question

Hello, I attempted to use an AI Agent step that involves the SQL agent. I used the PostgreSQL credentials hosted in AWS RDS and successfully tested them. However, when I ran the step, I encountered an error.

I have enabled the ignore SLL errors

What is the error message (if any)?

ERROR: self-signed certificate in certificate chain

Details

Stack

Error: self-signed certificate in certificate chain
    at TLSSocket.onConnectSecure (node:_tls_wrap:1600:34)
    at TLSSocket.emit (node:events:517:28)
    at TLSSocket.emit (node:domain:489:12)
    at TLSSocket._finishInit (node:_tls_wrap:1017:8)
    at TLSWrap.ssl.onhandshakedone (node:_tls_wrap:803:12)
    at TLSWrap.callbackTrampoline (node:internal/async_hooks:130:17)

AI Agent1

Test step

Parameters


Docs

Credential for Postgres

Agent

Data Source

Fixed

Expression

Prompt

Fixed

Expression

Options

Included Tables

Fixed

Expression

I wish this node would…

Problem in node ‘AI Agent1‘

self-signed certificate in certificate chain

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Information on your n8n setup

Version 1.26.0

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

hello @Antony_Rappai

I’ve had something similar. In my case, it helped to disable the option Ignore SSL Issues and set SSL to Disable state.
image

Ok thanks, that just did it for me too

I just tried this, but get the following error:

Any clues?