SSH Credentials

How to configure authentication via ssh correctly?

I’ve tried all these commands, and I always get the same error:
ssh-keygen -t ed25519 -C “[email protected]
ssh-keygen -t ed25519 -m PEM -C “[email protected]
ssh-keygen -m PEM -t rsa -b 4096 -C “[email protected]
ssh-keygen -p -m PEM -f ~/.ssh/id_rsa

I tried with and without the header

Information on your n8n setup

  • **n8n version: 0.227.0
  • **Running n8n via (Docker, npm, n8n cloud, desktop app): Docker

Hey @Wildson,

Welcome to the community :cake:

It looks like when we set the SSH key field as a password type it broke the data inside it and striped the new line characters. To work around this you can either set the key field as an expression and paste it in there or use an older version of n8n.

This should be changed in 0.228.0 though if you wanted to use an expression for now and change it later.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.