SSH node gets confused with files with spaces?

Hey guys,

I tried to download a file from my server over SSH. Setting resource as Command and with the command ls it found my file ls /home/andre/"bb dd.txt". But when setting resource as File and Operation as Download, it is not found. Setting Operation to Upload it creates a folder called "bb dd.txt". I tried single and double quotes. Is it a bug or am I doing it wrong?

As a workaround you could try using backslashes before your space chars.

1 Like

well, users shouldn’t have to escape characters like that.
I’ll have a look at this today, and see if I can send a PR.

2 Likes

and I will approve it :+1:

2 Likes

@andrebuhler in the upload operation, the Target input field is always the directory that the file gets uploaded into. This is why a new folder is getting created.
Can you try updating that field to use only the directory path in there, and set the filename via additional options in the Options section right below.

Regarding the download file operation, did you already try without single or double quotes?