SSH not working

Good afternoon, I don’t know English well so I can be mistaken. Installed 8n8 in the docker, I wanted to make a program for managing servers through ssh, well, the /bin/sh: ssh: not found error appeared. Looked at some topics with this problem. They advised installing n8nio/n8n:0.73.1-ubuntu, it has an ssh package. But the same error still appeared. What is the best way to install to make ssh work?

Welcome to the community @Zykov_Bogdan!

That should work. If you use the mentioned ubuntu-image and use an “Execute Command” node with the command ssh it should work. I just tried and for me it ouputs then totally correctly the usage information for ssh.

Here the node:

{
  "nodes": [
    {
      "parameters": {
        "command": "ssh"
      },
      "name": "Execute Command",
      "type": "n8n-nodes-base.executeCommand",
      "typeVersion": 1,
      "position": [
        553,
        353
      ]
    }
  ],
  "connections": {}
}

I tried to do everything again

sudo docker pull n8nio/n8n:0.73.1-ubuntu
0.73.1-ubuntu: Pulling from n8nio/n8n
1c6172af85ee: Pull complete 
b194b0e3c928: Pull complete 
1f5ec00f35d5: Pull complete 
93b1353672b6: Pull complete 
3d7f38db3cca: Pull complete 
21e102f9fe89: Pull complete 
224a0b313ce8: Pull complete 
24ea7952e196: Pull complete 
0cffdcdd6d94: Pull complete 
3c511049c9e4: Pull complete 
3b0cdf03de96: Pull complete 
b15052dd8f5d: Pull complete 
578a53cd1bf6: Pull complete 
Digest: sha256:d65a4f0b2845c22b04b491704fc00dbf9cdcacb27497217caf4452b035a710bc
Status: Downloaded newer image for n8nio/n8n:0.73.1-ubuntu
docker.io/n8nio/n8n:0.73.1-ubuntu

sudo  docker run -it --rm     --name n8n     -p 5678:5678     -v ~/.n8n:/root/.n8n     n8nio/n8n     n8n start --tunnel
[sudo] пароль для bogdan: 
Unable to find image 'n8nio/n8n:latest' locally
latest: Pulling from n8nio/n8n
cbdbe7a5bc2a: Pull complete 
8f3938f7d3bd: Pull complete 
6e3c12f5dc10: Pull complete 
ce0cb7a9eeee: Pull complete 
42847a35aee0: Pull complete 
6aa8717eed7b: Pull complete 
3039981bfff2: Pull complete 
9f5f302a7df7: Pull complete 
Digest: sha256:1848275a84e1fadf6d4a03c47ae583315e458fbe25808c0114db01b95db46035
Status: Downloaded newer image for n8nio/n8n:latest
UserSettings got generated and saved to: /home/node/.n8n/config

Waiting for tunnel ...
Tunnel URL: https://selfish-bull-34.hooks.n8n.cloud/

IMPORTANT! Do not share with anybody as it would give people access to your n8n instance!
n8n ready on 0.0.0.0, port 5678
Version: 0.73.1

Editor is now accessible via:
http:/localhost:5678/

Press "o" to open in Browser.

Did I do everything right?

The problem is that you pull one image (the ubuntu) and then start a totally different one (the not ubuntu).

You have to replace the image name in the command like this:

docker run -it --rm --name n8n -p 5678:5678 -v ~/.n8n:/root/.n8n n8nio/n8n:0.73.1-ubuntu n8n start --tunnel

I have an entrance to the server through the private key ssh, is it possible to add it to n8n for use?

Yes, you can simply mount the folder into the docker container as described here:

So the same what is happening with the .n8n folder with this part of the command:

-v ~/.n8n:/root/.n8n

You can do with any other folder by simply adding more in the same format:

-v <LOCAL_FOLDER>:<FOLDER_IN_DOCKER>

I try so that n8n gets access to my keys, but something does not work. Did I do everything right?

sudo docker run -it --rm --name n8n -p 5678:5678 -v ~/.n8n:/root/.n8n -v ~/.ssh:/root/.ssh n8nio/n8n:0.73.1-ubuntu n8n start --tunnel