SSL Error when using HTTP node


I am building a workflow with netsuite and getting an SSL error with a HTTP Node:
Error message is:

ERROR: SSL Issue: consider using the ‘Ignore SSL issues’ option
write EPROTO 384B3317447F0000:error:0A000438:SSL routines:ssl3_read_bytes:tlsv1 alert internal error:…/deps/openssl/openssl/ssl/record/rec_layer_s3.c:1586:SSL alert number 80

the workflow is currently its just one HTTP node to netsuite.
using “Ignore SSL issues” dos nothing the error is exactly the same.

Using postman collection I am able to do the exact connection but from n8n its failing.

Also the actual authentication method is Oauth 1.0 but it has 4 tokens and so I cannot use the Oauth (pre configured) header for certificate and placing all the data in a normal Authentication header instead

n8n setup:

  • n8n version: 1.3.1
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker compose
  • Operating system: ubuntu

Thank you.

Hi @Skrymor, I am so sorry you’re having trouble. Can you confirm the URL you’re trying to call so I can take a closer look at the certificate and what might be the problem here?

Also, could you share the HTTP Request node you are currently using (you can of course redact any confidential values, I’d just like to check which version of the node you are currently using)?


Ill transfer the URL in a private message as the URL holds some information that I dont want to show publicly, Regarding the n8n http node, here it is:

And again using postman collection this all works fine without any errors.

Hi @Skrymor, thank you so much for sharing these details!

I was able to reproduce the problem and will add it to our internal bug tracker for the team to look into.

My guess is that n8n is using a version of TLS that isn’t supported by the server here.

Hey MutedJam,

By any chance is there any ETA/When will the fix be applied? maybe with upcoming 1.6.1 or after that?


upcoming 1.6.1

Doesn’t look like it I am afraid, but perhaps our product man @sirdavidoff can provide an ETA here.

Try to fix with the 1.6.1 version just released


Just updated to version 1.6.1 and unfortunately still the same error:

{“status”:“rejected”,“reason”:{“message”:“write EPROTO 585B5A24197F0000:error:0A000438:SSL routines:ssl3_read_bytes:tlsv1 alert internal error:…/deps/openssl/openssl/ssl/record/rec_layer_s3.c:1586:SSL alert number 80\n”,“name”:“Error”,“stack”:“Error: write EPROTO 585B5A24197F0000:error:0A000438:SSL routines:ssl3_read_bytes:tlsv1 alert internal error:…/deps/openssl/openssl/ssl/record/rec_layer_s3.c:1586:SSL alert number 80\n\n at WriteWrap.onWriteComplete [as oncomplete] (node:internal/stream_base_commons:94:16)”,“code”:“EPROTO”}}


Hey @Skrymor,

There have been no changes that I am aware of that would help with this. I did take a very quick look at a similar issue earlier that had the same error message.

For science can you remove the Host header from your HTTP Request and let me know if that works? I have a feeling it might solve the problem.

I’ve made sure this issue is on the relevant internal team’s board for investigation. Hard to give an ETA though, I’m afraid.

Thank you,
Also @Jon you are correct in regards to removing the host but then ill receive invalid credentials.
Using Postman with exactly same settings (with host header) works just fine.


Hey @Skrymor,

I would stick to not including the host header for now, If you getting invalid credentials that is a good sign and would suggest there could be a second issue.

As an example if I use the http request to get and include the same host header I get the same error message, I believe this is because we automatically include the host header so you don’t need to.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

New version [email protected] got released which includes the GitHub PR 8562.