Still seeing the update notification inside n8n

Describe the problem/error/question

I have n8n hosted in DigitalOcean Droplet.
I saw that there was an update, so I went to the console.

I Updated as I always do
cd < dir > then:
Docker compose pull
Docker compose down
Docker compose up -d

But I still see this on n8n

image

And the current version is
image

Information on your n8n setup

  • n8n version: 1.42.1
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

hello @brahimh

I’ve noticed the same. I suppose the issue is that that version is a pre-release, so the docker:latest doesn’t work with it yet.

image

@Jon or @bartv FYI

1 Like

Oooh okay, got it

I had the same problem with the previous update as well :slight_smile:
So it shows up before it’s possible to update I guess…

I see that it updated on Github
image

But Just performed the update now, and I still have the same version :slight_smile:
image

Arc 2024-06-06 4.09.13 PM

Hey @brahimh,

You can update to 1.44.1 but if you get that version depends on what tag you have your docker compose file set to use.

If you are using docker.n8n.io/n8nio/n8n or docker.n8n.io/n8nio/n8n:latest it will use whatever version is currently tagged as latest which as of right now is 1.44.1 which changed from 1.42.1 about 30 minutes ago so if you did the process now you would get the new version.

If your compose file is using docker.n8n.io/n8nio/n8n:next you would get version 1.45.0 which was released yesterday and may contain issues.

But why the UI shows us the pre-release versions? :slight_smile:

They are only “pre-release” in GitHub, once the docker image is released it is ready for anyone to update to.

While some users may prefer to use the latest tag others use the next tag and the notification is there to let you know a newer release is available which is technically correct.

It works now, thanks


But I got another problem with one of the deployments and IDK Why…

I removed all the executions history and still the same problem

It says you don’t have enough free space…

maybe docker has a lot of cache there

Any idea how I can solve this?
Without impacting my n8n installation ofc :slight_smile:

Also, I deleted ~10k records from the execution history, There might have been a bug there and they weren’t removed [For a heavy CRM API], each one of those executions will have a few MB per run… I don’t see anything in the execution history section currently tho… :confused:

I would start with docker image prune -a.

Plus maybe you don’t have settings to clear the old executions:

  • EXECUTIONS_DATA_PRUNE
  • EXECUTIONS_DATA_MAX_AGE
  • EXECUTIONS_DATA_PRUNE_MAX_COUNT
2 Likes

Ran docker image prune -a

Is it supposed to be taking this much space?
[I have 8 workflows]

(I was able to update, thanks for the help)

So the old executions don’t clear unless I clear them?
I’d love a setting to clear anything older than 1 week

Any idea how I can set this up?

especially this one:

Seems like it’s removed after 14days by default?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.