Stripe output data

Describe the problem/error/question

Hello good n8n people,

I have several Stripe triggers in my workflows. Recently (not so recently - it will be at least two weeks) the nodes stopped showing the output data. That applies also to HTTP Requests done to Stripe. I could not find anything in the changelogs and everything still works - the data is there, just not visible. It is just more difficult to work with stripe a debug. Interestingly there is an IF node after the Stripe trigger node and that IF node comfortably shows all the data it got from the Stripe node (different workflow shown below).

Was there any recent change in the stripe triggers?

I also tried to replace the HTTP request with a new one and it showed the output data fine until I went out and back in to the editor.

What is the error message (if any)?

No errors shown.

Please share your workflow

Workflow overview

This picture shows the HTTP request node. You can see that it got “no data” from the Stripe trigger and also did not return any data. But the expression is green and therefore satisfied.

Based on the data from Stripe I am then looking in Ghost if the customer already exists. As you can see I found a member even though the previous node did not show any data.

This is happening on multiple computers on latest Firefox and Opera.

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.14.2
  • Database (default: SQLite): postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Unraid

Hi @Drearily5829 :wave: Can you try removing the . from the node names, and seeing if that fixes it up? If it does, I’m afraid you’ve been hit by a bug our engineering team knows about :see_no_evil:


Yup! That is it! :smiley: Thank you.

Tried it on the HTTP request and it shows output data now. It also fixes Edit Fields node. Is that something that you can fix eventually? I come from non coding background so it did not struck me as an obvious mistake immediately.

I will delete the dots now.


Hi @Drearily5829 - glad this was the answer! The team knows about it, I’ll mention your instance of this and will be back with any updates on the issue :bowing_man:

1 Like

Ok. No rush from my side! You are doing excellent job. Thank you for your help!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

New version [email protected] got released which includes the GitHub PR 8013.