Supabase: delete with a metadata filter

I am looking for a way to re-insert some elements in Supabase vector store. Therefore i am looking for a way to delete some parts of my documents with the supabase node where i have to filter based on metadata. When i select metadata as criteria it show “metadata - (undefined)” and i do not see now i can put my criteria in. The native query is “delete from documents where metadata ->> ‘collection’ = ‘projekte’;” How can it be done?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @MehrCurry,

This is not something I have tried but have you tried using the delete option inte Supabase node with the string option to see if that helps or maybe connecting directly to the Supabase database with the Postgres node?

Thanks for the hint. Did not really know what to do with the string option. I figured out the correct syntax using ChatGPT and it works. For all with the same problem the string i use is metadata->>collection=eq.projekte.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.