Super slow UI and spikes in CPU usage and disk I/O

Describe the issue/error/question

I created a workflow that triggers every minute. Everything was good and well. Until I duplicated the workflow. I basically would need to have a bunch of similar workflows running at the same time.

Although, it seems like the CPU usage and disk I/O spikes like crazy out of nowhere. I tried to update n8n and deactivate the workflows. But even after deactivating them, it would take a few minutes to load n8n or refresh it. I also tried to delete the executions (24,000-something executions), but it seems that it slows down when I try to do so. I deactivated the saving of the executions in the workflows. But weirdly, the executions sometimes do not appear and sometimes they do.

What is the error message (if any)?

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.220.0
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]: Tried to change to main (not sure if it was successful)
  • Running n8n via [Docker, npm,, desktop app]: Docker

I duplicated the workflows and deleted the ones with thousands of executions. Looks like all the saved executions are finally gone. And it seems like the resources used are more stable. I’ll report tomorrow if that solved it.

Hey @Kenny_Alami,

Duplicated workflows shouldn’t cause an issue, was there any output in the docker logs? When you were watching the resource spikes was that for the container itself or the host?

How many workflows did you have as well? While just duplicating workflows shouldn’t have an issue if you were running a bunch of workflows every minute that could cause some issues if the resources are not there to support it.

Hi @Jon, thanks for the reply!

I’m not sure how to get the docker logs.

Here is a screenshot to answer your question. Except for that massive spike around 9 am. Everything else looked okay.

I also had a bunch of failed executions.

The ones that are more than 10 minutes show a memory error. But the others ones don’t display any error message.


I have two workflows running simultaneously every minute right now. The idea is to have 5 and more later.

My config so far is 1 GB Memory and 25 GB Disk.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.