Switch Node - Wrong Output Numbers after Update 0.216.0

Describe the issue/error/question

After updating from 0.212.1 to 0.216.0 all workflows are automatical updated, if a switch node is included and reordered the output numbers.

Here the git update (i am using auto Backup):

the result:


In the Node there where fix output 0.

What is the error message (if any)?

All Workflows with switch Node are doing it wrong now!

Information on your n8n setup

  • n8n version: 0.216.0
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Hi @ChristianV, I am so sorry for the trouble. I haven’t observed this myself and from taking a quick look at the changelog it’s not obvious to me which change exactly could be causing this unfortunately.

I’ll flag this internally, hoping anyone else might know more about this one.

@MutedJam , thanks. it looks like on if nodes too, but not always.

it looks like, if the first output 0 is not used, it will remove it and update the following numbers.

Thank you, I was also able to reproduce this myself in the meantime. Hope this will get fixed soon, it looks rather bad tbh. I have countless workflows like these (where not all outputs of the Switch/IF nodes are being used) myself and I am not looking forward to reviewing them.

It seems the change causing the problem went out with 0.214.3 which introduced a migration removing empty connections.

We’ll keep you posted on a fix, though for now you probably want to restore a backup from before the upgrade.

New version [email protected] got released which includes the GitHub PR 5546.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.