Switch Not Working As Expected - Output Not Showing Data

HI Guys,

I have the following output from a switch node. I have confirmed that the field used for the switch is indeed a number field (if that makes a difference), however when i run it, it doesn’t output to output 0 as I expect it would? Here’s an example of the switch node and the output.

Information on your n8n setup

  • n8n version: 1.20.0
  • Database (default: SQLite): Postgres
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Railway

@Damien_Kelly , what is the original data at the input of the Switch? Most likely it is a type mismatch or the wrong path to the data. If you add the fallback output you will probably see your item in there.

Thanks very much for your response. I thought that as well, I have a ‘set’ in the step prior with the following, should that make it a ‘number’ type?

An example of the input data is as follows;

Sorry, Ive just reviewed it again and absolutely it was a type mismatch. I have just checked everything again and it has worked now.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.