SyntaxError: identifier starts immediately after numeric literal


First of all, n8n is awesome. Is a life saver. Thank you guys for the great work!

Describe the issue/error/question

A few days ago I started not being able to access the visual interface anymore.

What is the error message (if any)?

In the Javascript Console, the following error appears:

SyntaxError: identifier starts immediately after numeric literal

Any idea or workaround?

Thank you!

Information on your n8n setup

  • n8n version: 0.214.2
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm,, desktop app]: PM2

I just did a rollback to version 0.213.0 and it worked again.

1 Like

Hey @Lauro_Becker,

Welcome to the community :cake:

That is a bit strange, did the PM2 log show any errors?

Hey, Jon!

I know it sounds weird, but it’s working in Chrome, and it’s not in Firefox.

This is the only error:

1|n8n      | (node:15592) [PINODEP008] PinoWarning: prettyPrint is deprecated, look at for alternatives.
1|n8n      | (Use `node --trace-warnings ...` to show where the warning was created)

Maybe it was some problem in the compilation of the assets?

Thank you!

Could be, I just gave the latest release a go in Firefox instead of Brave and it looks to be all good now. Might be worth an upgrade to see if the latest release is all good.

I’ll do it. Thanks!

1 Like

Hi @Jon ,
I can confirm this exact issue happens on version 0.213.0.
The login page loads fine in Chrome, but errors out and stays blank in Firefox.

After switching to the latest release (0.220.0), the situation gets worse because it doesn’t work on Chrome anymore:

This kinda looks like a bundling issue.

Did you find a solution, @Lauro_Becker ?

I rolled back to 0.210.0, and this one works both on Chrome & ff:

Hey @occupytheweb,

Welcome to the community :tada:

0.220.0 should be fine in Chrome that is what I have been using on one of my machines without issue, Looking at the URL for your instance you are self hosting and Cloudflare is in use. Are you using a Cloudflare tunnel or any of their caching options as well?


The last version works for me.

Sometimes it doesn’t work on Firefox.

I’m using Cloudflare.

1 Like

Hey they @Jon .
Thanks, I’m glad to be here ! :smile:

Indeed, that deployment was a Docker-based self hosted one, with Cloudflare as DNS provider. Though, it was not using Tunnels.
It indeed looks like I’ve been running into some caching issues, as it now looks to be working fine on both Chrome and Firefox.

Thanks for your assistance!
And thanks for your reply, @Lauro_Becker !

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.