Telegram bot is working slowly

Hi. I made a simple bot, but it doesn’t respond super fast. I changed the EXECUTIONS_PROCESS setting to main.

What other settings do I need to make for the bot to respond faster?

What power does a VPS server need ? (now 1 ram 1 core)

Information on your n8n setup

  • n8n version: 0.228.2
  • Database: SQLite
  • n8n EXECUTIONS_PROCESS setting: main
  • Running n8n via: Docker
  • Operating system: Ubuntu 20.04

Hey @Danilov_Vovka,

How fast is it responding and what speed are you expecting? The speed is going to come down to resources and what the workflow is actually doing but typically 1GB / 1 Core would be enough for some basic tasks and should result in a fairly quick response.

I did a quick test on a basic Digital Ocean droplet and I was getting a reply back in under a second with a simple response.

Now I have increased the RAM to 2 GB just in case.
Created a test bot and a test workflow.
The response time to the message is equal to : 6 seconds

Workflow and bot test screenshots attached.


It is very strange that the workflow execution time in the n8n logs writes 0.407, but in fact it is 6 seconds.

Are you sure the execution process has been set to main correctly? Are you also using a reverse proxy or something like cloudflare?

  1. I have n8n running through docker compose. I just inserted the option into the .env file, then executed the docker-compose down command and launched the docker-compose up -d command
  2. No

What command can I use to check this mode when n8n is running ?

Hey @Danilov_Vovka,

Can you share your compose file? The .env file there on its own won’t set the execution process mode.

Hey @Danilov_Vovka,

So in that set up Traefik is a reverse proxy but should be ok, can you add the execution process option to the environment section of the compose file and stop the container then start it again this should in theory fix the issue.

1 Like

You are a genius, thank you, it really helped and now the bot responds with lightning speed.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.