Telegram Trigger node doesn't catch webhooks, when scenario isn't active

Hello, guys!
I have a problem with receiving webhooks by the Telegram Trigger node. When I’am clicking on «Listen For Event» or «Execute workflow» and sending some message to my bot, nothing is happening. But, when I switch scenario status to «Active», I see JSON-data in «Executions». I cannot develop scenarios if I’am not getting data in real-time :slight_smile:

Could you help me with my issue?

About my server and configurations: I deployed n8n on Ubuntu 20.04 VDS by docker-compose and configured by nginx.

My nginx config:

server {
    server_name  n8n.example.ru;
    include /etc/nginx/templates/letsencrypt.conf;

    location / {
        proxy_pass  http://localhost:8082;
        proxy_set_header Host $host;
        proxy_set_header X-Forwarded-Host $host:$server_port;
        proxy_set_header X-Forwarded-Proto https;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    }


    listen 443 ssl; # managed by Certbot
    ssl_certificate /<address>/fullchain.pem; # managed by Certb>
    ssl_certificate_key /<address>/privkey.pem; # managed by Cer>
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}



server {
    if ($host = n8n.example.com) {
        return 301 https://$host$request_uri;
    } # managed by Certbot


    server_name  n8n.example.com;
    listen 80;
    return 404; # managed by Certbot


}

In the environment variables I’am using only

WEBHOOK_URL: "https://n8n.example.com/"

because when I’am adding N8N_PORT, it gives the 502 issue

n8n version: 0.178.2


Fun fact: I opened port 8082 and connected to the n8n directly like http://<ip_address>:8082 – in this case UI works correctly, and I gets JSONs from Telegram. But how I can fix it for the https version with domain?

Issue is solved. If you have the same trouble with getting JSONs on your UI side, add into the Nginx config next method:

proxy_buffering off;

You can find more details about this feature in the official documentation: Module ngx_http_proxy_module

I found the solution in this topic:

1 Like

Welcome to the community @moostanger!

Glad to hear you figured it out, thanks so much for confirming and for sharing the solution!

1 Like