Telegram trigger works 2 minutes after start

Describe the issue/error/question

I started n8n with command: n8n start --tunnel
telegram trigger works few minutes after start, then it stop working

What is the error message (if any)?

no error messages. if I check tunnel URL in google chrome after that, I got 404/408 errors

Please share the workflow

Share the output returned by the last node

if it doesn’t work, it returns nothing. if it works, I got “pong” in chat. screenshot:

Information on your n8n setup

  • n8n version: 0.186.1
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm,, desktop app]: npm

Hi @Yarkiy, welcome to the community!

I am sorry to hear you’re having trouble here.

Are you by any chance testing multiple different workflows or manually run this workflow in the meantime? Afaik, Telegram only supports a single active webhook at a time.

So adding a new Telegram trigger will break existing Telegram trigger nodes. The same would happen if you manually executing a workflow including a Telegram trigger while your workflow is active (as this will register a new webhook with Telegram using the test URL and thus disable the production one).

Hi @MutedJam
I only have one workflow. I’ve been trying to beat this error for 2 days now.
restarting n8n fixes the error for about 2 minutes, after which the trigger stops working on one’s own
trying to delete and re-add the workflow, re-create the bot, delete and re-add the token does not fix the error
my programming skill is low and i can’t set my own URL to avoid using tunnel URL

So this could suggest an unstable network connection breaking the tunnel after a bit.

If so, the tunnel URL might indeed be the culprit here. The desktop app doesn’t support your own URLs, but a self-hosted server deployment would (though this can be a lot of work, especially if you have not done this before).

To rule out network problems you could also consider signing up to n8n cloud temporarily (this is a paid service, but the first 30 days are free).

can you help me to add my own URL please?

  1. I have static IP address and get DDNS from
  2. in server console I send command: export WEBHOOK_URL=https://MYDDNSNAME/
  3. then I run n8n without --tunnel: n8n start
  4. on router firewall rules I send to server all TCP traffic from 443 port.
    that’s all?

Your router might not handle SSL termination (you might need a reverse proxy for that or add existing SSL certificates to n8n using the N8N_SSL_CERT and N8N_SSL_KEY environment variables).

For an n8n set up that generates its own valid SSL certificate and is capable of listening on port 80 + 443 you might want to use the docker compose approach described here.

My personal approach is described here.

Hope this helps!

Error is hiding somewhere in my home router (MikroTik hap ac^2) or home server with Ubuntu Server 22.04.
Running n8n in docker didn’t solve the problem.
Migrating the server to the Oracle cloud server on Ubuntu Server 20.04 solved the problem.

1 Like

Glad to hear this worked for you, thanks so much for confirming!