Test executions not working properly


Hi! I have two instances of n8n running. Both are basically exact same. First is on Beget.tech hosting while other is on my own server. Only difference is that second instance running without traefik (it is already behind reverse-proxy) and has more services like qdrant, minio and others.

On beget’s instance everything works great, while on my instance Executions from editor does not work properly. Its working, but editor says it is running infinite time unless I press stop button. If I press it two things can happen:

  1. In case execution was success: execution stops and test data is present.
  2. In case execuition stopped with error: There is an error pressing stop button and workflow continues “executing” unless I reload a page.

More information in video I recorded on both instances
First is beget’s hosting which shows desired behavior. Next is mine which shows undesired behavior.

Video on youtube


Workflow is basically anything. I use Manual Trigger + Set Fields

Information on both n8n setup

  • n8n version: 1.26.0
  • Database (default: SQLite): PostgreSQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main): regular
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Debian

Hey @mr-good-bye,

On your server can you try connecting using the IP directly to see if that works as expected? I suspect the issue is likely to be with the reverse proxy configuration and connecting with the IP will help either confirm or rule that out.

1 Like

Yeap, everything works. What could be the problem?
My scheme is:

  1. N8N running with port 5678, so when I “locally” open it (not through reverse-proxy) - I open it http, not https, in other case I got SSL error as I have no cert on my server
  2. Reverse-proxy only reversing mydomain.domain:443 (https) to localaddress:5678
    Can you help me sort that out? I had no success googling out how to configure that properly without traefik but with nginx. My server is already behind nginx and there are no way I could bypass it (I have no IP left, only subdomain)
    There’s an error I found, any thought how could I solve that problem?
    Could changing to SSE help me?

Hey @mr-good-bye,

Changing to SSE could help but I would recommend configuring your nginx setup to support websockets. For nginx it will be something like…

server {
  listen 443 ssl;
  server_name n8n.my_domain.tld;
  location / {
    proxy_set_header Connection 'Upgrade';
    proxy_set_header Upgrade $http_upgrade;
    proxy_http_version 1.1;
  ssl_certificate # removed
  ssl_certificate_key # removed