Test-Webhook from baserow to n8n creates 404

Hi guys,

I want to create a webhook to n8n that gets fired with every new row that got created in baserow.
But somehow it is not working.
(I tested a make-webhook and that one worked. :thinking:)

Any idea why my webhook is not working?

Bildschirmfoto 2023-12-05 um 08.17.05
https://spicy-duck-23.hooks.n8n.cloud/webhook-test/10537198-39c7-43d8-918d-4c48d313c031

While linking that webhook I get this message:

What do I have to change?

(Both are self-hosted on docker: baserow version 1.21.2 & n8n version 1.16.0)

Thank you and best regards

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @martin23,

Can you restart your n8n container I suspect the tunnel connection crashed and you have a new URL now. I would also advise against using the tunnel if you are trying to use n8n for more than just testing.

Hi Jon,

thank you for your response.

As suggested I restarted my n8n-container.
Then, I copied the new test-webhook-url
https://shaggy-fox-69.hooks.n8n.cloud/webhook-test/10537198-39c7-43d8-918d-4c48d313c031
to baserow and got an 404-error in baserow, again.
:face_with_raised_eyebrow:

I am working on n8n on the same url as always (but no httpS)

sudo docker run -it --name n8n -p 5678:5678 --restart always  -d -v n8n_data:/home/node/.n8n docker.n8n.io/n8nio/n8n:[Version] start —tunnel

(What is the alternative to a tunnel, if I want that n8n is still running although my computer is offline? n8n should be independent from the online-/offline-status of my computer.)

Thank you and best regards

Use n8n cloud or host on a vps or whatever to fix the tunnel thing. :slight_smile:

Also I see u have it set to GET in n8n. Baserow is sending. POST

Ok …

Now, I quitted with the tunnel on n8n.

I got this webhook-url:
http://localhost:5678/webhook-test/10537198-39c7-43d8-918d-4c48d313c031
and my http-method on n8n is GET.
I inserted this webhook-url in my browser, replaced localhost with my server-ip-adress, added two words for query and it works fine.
Bildschirmfoto 2023-12-20 um 13.15.06

Then I inserted the webhook-url to baserow but I got the message that this url is invalid, inaccessible or prohibited … :thinking:


I replaced localhost with my server-ip-adress with the same result: The url is invalid, inaccessible or prohibited.

Then – because the webhook to make is working – I tried to use a make-szenario to pass the information to my n8n webhook.


This works, too.

Bildschirmfoto 2023-12-20 um 14.18.28

So I am wondering right now, why baserow and n8n are not able to communicate with each other directly …
:thinking:

No one with an idea?

Hey @martin23

Baserow won’t be able to reach n8n on localhost unless you have both n8n and baserow running on the same machine and not in a container.

As you are using docker you will need to configure the docker networking to allow both containers to talk to each other, Depending on your current configuration it could be as easy as just pointing the Baserow webhook to 172.17.0.1:5678.

1 Like

I was looking for this!!! I had the same problem, this solved my issue since I’m a docker newbie!

1 Like