The node-type "httpRequest" is not known!


I’m currently on the Getting Data From the Data Warehouse part of the level 1 course. On the http request node there is no option to Split into items, and when I run the node it says The node-type “httpRequest” is not known!


  "meta": {
    "instanceId": "2fc53533640c52d99f1ec56e2cb1738380e2ec75f2cb244069589a358e3cc25c"
  "nodes": [
      "parameters": {
        "url": " ",
        "authentication": "genericCredentialType",
        "genericAuthType": "httpHeaderAuth",
        "sendHeaders": true,
        "headerParameters": {
          "parameters": [
              "name": "unique_id",
              "value": "***************"
        "options": {}
      "id": "04ef749b-52d1-4a55-9353-c9e71d62c085",
      "name": "HTTP Request",
      "type": "httpRequest",
      "typeVersion": 3,
      "position": [
      "credentials": {
        "httpHeaderAuth": {
          "id": "1",
          "name": "Header Auth account"
  "connections": {}

This is on windows desktop, but I tried it on the cloud version and it didn’t have the split into items option either.

Thank you!

Hey @Mina,

Welcome to the community :raised_hands:

We recently changed the HTTP Request node and have not yet updated the course with the changes, The node will now automatically split the items if possible so that you don’t need to worry about it. The node below should do what you are after and you can copy / paste it into the editor.

1 Like

Thank you so much!

It’s working now :grinning:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.